파이썬 pip 버전 업그레이드 (업데이트) 하는법

파이썬을 사용하다보면 다양한 모듈을 설치하거나 불러오게 되는데요 가끔 에러코드 문구가 뜨는 경우 매우 당황할 수 있습니다

물론 파이썬을 최신 버전으로 설치 했다고 해도 pip 오류 문제가 뜰 수 있기 때문에 이점은 반드시 해결해주셔야 합니다

파이썬 pip version 업그레이드 오류 같은 경우 대표적으로 아래와 같이 뜨게 되는데요

you are using pip version 8.1.2, however version 9.0.1 is availabe.

이런식으로 모듈을 실행하는데 필요한 pip 버전을 보여줍니다

파이썬 pip 버전확인

우선 자신의 pip 버전이 무엇인지 부터 알아보기 위해서는 아래 코드를 입력해 주시면 됩니다

그리고 현재 설지된 모듈과 버전들을 확인할 수 있는 명령어도 참고하시길 바랍니다

pip --version    #    pip 버전확인
pip list        #  설치된 모듈 패키지 목록 확인
pip install  패키지 모듈이름    #  모듈 패키지 설치
pip uninstall       # 모듈 패키지 삭제 제거

파이썬 pip 업그레이드

pip install --upgrade pip      # pip 업그레이드

파이썬 모듈 업그레이드를 할때 가끔 cannot uninstall 오류가 생기는 경우가 있습니다 이런 경우 pip install 뒤에 –ignored -installed 를 붙여주시면 해결이 되는데요 아래 포스팅을 참고하시길 바랍니다

파이썬 Cannot uninstall 'pyserial' 오류 해결방법

Leave a Reply

Your email address will not be published.