xlrd.biffh.XLRDError: Excel xlsx file; not supported 오류 해결법

파이썬에서 엑셀 파일을 불러오기 할때 나오는 오류가 있는데요 xlrd.biffh.XLRDError: Excel xlsx file; not supported 위 문구가 뜨쎴다면 xlrd 패키지 문제일 수 있습니다 xlrd 패키지는 엑셀파일 읽기에서 필요한 패키지 이지만 xls 파일 이외 xlsx 파일을 지원하지 않기 때문에 나오는 오류라고 할 수 있습니다 하지만 해결방법이 있습니다 먼저 pandas 버전이 1.0.1 이상이여야 하고 openpyxl 설치가 필요합니다 그리고 … Read more

tensorflow 설치 오류 해결 cudart64_101.dll cusolver64_11.dll

윈도우10에서 파이썬 tensorflow 설치 오류가 나오는 경우가 있는데요 대표적으로 아래 오류 문구를 확인해볼 수 있습니다 Could not load dynamic library ‘cudart64_101.dll’; dlerror: cudart64_101.dll not found 또는 버전이 맞지 않는 경우 아래 문구가 뜨는 경우도 있는데요 Could not load dynamic library ‘cusolver64_11.dll’; dlerror: cusolver64_11.dll not found cusolver64_11.dll 오류 tensorflow 설치 오류 원인 첫번째 의 경우 tensorflow … Read more

파이썬 Cannot uninstall ‘pyserial’ 오류 해결방법

파이썬 pip 모듈 설치 또는 제거 시 It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall. 오류가 뜨는 경우가 있습니다 이런경우 무시 옵션을 추가 하셔서 설치를 해주시면 됩니다 Cannot-uninstall-pyserial-오류-해결 위 그림과 같이 pip install 뒤에 ignored-installed 를 추가하셔서 진행하시면 … Read more

파이썬 pip 버전 업그레이드 (업데이트) 하는법

파이썬을 사용하다보면 다양한 모듈을 설치하거나 불러오게 되는데요 가끔 에러코드 문구가 뜨는 경우 매우 당황할 수 있습니다 물론 파이썬을 최신 버전으로 설치 했다고 해도 pip 오류 문제가 뜰 수 있기 때문에 이점은 반드시 해결해주셔야 합니다 파이썬 pip version 업그레이드 오류 같은 경우 대표적으로 아래와 같이 뜨게 되는데요 you are using pip version 8.1.2, however version 9.0.1 … Read more